Skip to content

Technical requirements

Please use personal laptop for development (or RDP to somewhere)

School pc-s are not updated that frequently. You don’t have admin rights, can’t install some of the required components.

SDK

Download and install .NET 6.0 SDK - all platforms supported.
Update regularly!

IDE – your choice

JetBrains Rider or VS Code (Rider preferred and has best support by teachers - ie. our personal choice)

Visual Studio (any edition) + JetBrains ReSharper

JetBrains Rider or VS for macOS (no ReSharper add-on exists for VS for macOS)